题目链接:https://www.starrycoding.com/problem/160
题目描述
给定一个整数 n n n,输出阶乘 n ! n! n!。
输入格式
一个整数 n ( 1 ≤ n ≤ 20 ) n(1 \le n \le 20) n(1≤n≤20)。
输出格式
一个整数 n ! n! n!。
输入样例1
16
输出样例1
20922789888000
题解
#include <bits/stdc++.h>
using namespace std;
using ll = long long;
void solve()
{
ll n;
cin >> n;
ll ans = 1;
for (int i = 1; i <= n; ++i)
ans = ans * i;
cout << ans << '\n';
}
int main()
{
ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
int _ = 1;
while (_--)
solve();
return 0;
}
提交记录:https://www.starrycoding.com/submission/5173