配置IPv4静态路由示例
组网需求
如图1所示,STA1、STA2和PC1属于不同网段,STA1在AP1中上线,STA2在AP2中上线,要求配置静态路由,使PC1与STA1和STA2能够互通。
配置思路
采用如下的思路配置IPv4静态路由:
- 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通。
- 在主机上配置IP缺省网关,在AP1,AP2和SwitchA上配置IPv4静态路由或者静态缺省路由,实现PC1与STA1和STA2之间能够互通。
操作步骤
- 配置STA1在AP1中上线,STA2在AP2中上线
配置AP1的业务VLAN为VLAN30,STA1在AP1中上线,STA1获取的IP地址为1.1.1.254/24。具体配置请参见配置FAT AP二层组网示例。
配置STA2在AP2中上线(略)。
- 在AP1上配置GE0/0/1接口所属VLAN
<HUAWEI> system-view [HUAWEI] sysname AP1 [AP1] vlan batch 10 [AP1] interface gigabitethernet 0/0/1 [AP1-GigabitEthernet0/0/1] port hybrid pvid vlan 10 [AP1-GigabitEthernet0/0/1] port hybrid untagged vlan 10 [AP1-GigabitEthernet0/0/1] quit AP2的配置同AP1(略)。 在SwitchA上配置各接口所属VLAN(略)。
- 在AP1配置各VLANIF接口的IP地址
[AP1] interface vlanif 10 [AP1-Vlanif10] ip address 1.1.4.1 30 [AP1-Vlanif10] quit [AP1] interface vlanif 30 [AP1-Vlanif30] ip address 1.1.1.1 24 [AP1-Vlanif30] quit AP2的配置同AP1(略)。 在SwitchA上配置各VLANIF接口的IP地址(略)。
- 配置PC1和STA
配置主机PC1的缺省网关为1.1.2.1,由于STA1和STA2在AP1和AP2上线,STA1的网关为1.1.1.1,STA2的网关为1.1.3.1。
- 配置静态路由
# 在AP1配置IP缺省路由。 [AP1] ip route-static 0.0.0.0 0.0.0.0 1.1.4.2 # 在SwitchA上配置两条IP静态路由。 [SwitchA] ip route-static 1.1.1.0 255.255.255.0 1.1.4.1 [SwitchA] ip route-static 1.1.3.0 255.255.255.0 1.1.4.6 # 在AP2配置IP缺省路由。 [AP2] ip route-static 0.0.0.0 0.0.0.0 1.1.4.5
- 验证配置结果
#查看AP1的IP路由表。 [AP1] display ip routing-table Route Flags: R - relay, D - download to fib ------------------------------------------------------------------------------ Routing Tables: Public Destinations : 10 Routes : 10 Destination/Mask Proto Pre Cost Flags NextHop Interface 0.0.0.0/0 Static 60 0 RD 1.1.4.2 Vlanif10 1.1.1.0/24 Direct 0 0 D 1.1.1.1 Vlanif30 1.1.1.1/32 Direct 0 0 D 127.0.0.1 Vlanif30 1.1.1.255/32 Direct 0 0 D 127.0.0.1 Vlanif30 1.1.4.0/30 Direct 0 0 D 1.1.4.1 Vlanif10 1.1.4.1/32 Direct 0 0 D 127.0.0.1 Vlanif10 127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0 127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0 127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0 255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0 # 使用ping命令验证连通性。 [AP1] ping 1.1.3.1 PING 1.1.3.1: 56 data bytes, press CTRL_C to break Reply from 1.1.3.1: bytes=56 Sequence=1 ttl=254 time=62 ms Reply from 1.1.3.1: bytes=56 Sequence=2 ttl=254 time=63 ms Reply from 1.1.3.1: bytes=56 Sequence=3 ttl=254 time=63 ms Reply from 1.1.3.1: bytes=56 Sequence=4 ttl=254 time=62 ms Reply from 1.1.3.1: bytes=56 Sequence=5 ttl=254 time=62 ms --- 1.1.3.1 ping statistics --- 5 packet(s) transmitted 5 packet(s) received 0.00% packet loss round-trip min/avg/max = 62/62/63 ms # 使用Tracert命令验证连通性。 [AP1] tracert 1.1.3.1 traceroute to 1.1.3.1(1.1.3.1), max hops: 30 ,packet length: 40, press CTRL_C to break 1 1.1.4.2 31 ms 32 ms 31 ms 2 1.1.4.6 62 ms 63 ms 62 ms
配置文件
AP1的配置文件
#
sysname AP1
#
vlan batch 10 30
#
interface Vlanif10
ip address 1.1.4.1 255.255.255.252
#
interface Vlanif30
ip address 1.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
port hybrid pvid vlan 10
port hybrid untagged vlan 10
#
ip route-static 0.0.0.0 0.0.0.0 1.1.4.2
#
return
SwitchA的配置文件
#
sysname SwitchA
#
vlan batch 10 20 40
#
interface Vlanif10
ip address 1.1.4.2 255.255.255.252
#
interface Vlanif20
ip address 1.1.4.5 255.255.255.252
#
interface Vlanif40
ip address 1.1.2.1 255.255.255.0
#
interface GigabitEthernet0/0/1
port hybrid pvid vlan 10
port hybrid untagged vlan 10
#
interface GigabitEthernet0/0/2
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
interface GigabitEthernet0/0/3
port hybrid pvid vlan 40
port hybrid untagged vlan 40
#
ip route-static 1.1.1.0 255.255.255.0 1.1.4.1
ip route-static 1.1.3.0 255.255.255.0 1.1.4.6
#
return
AP2的配置文件
#
sysname AP2
#
vlan batch 20 50
#
interface Vlanif20
ip address 1.1.4.6 255.255.255.252
#
interface Vlanif50
ip address 1.1.3.1 255.255.255.0
#
interface GigabitEthernet0/0/1
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
ip route-static 0.0.0.0 0.0.0.0 1.1.4.5
#
return