【题目来源】
https://www.acwing.com/problem/content/1641/
【题目描述】
这是 2018 年研究生入学考试中给出的一个问题:
以下哪个选项不是从给定的有向图中获得的拓扑序列?
现在,请你编写一个程序来测试每个选项。
【输入格式】
第一行包含两个整数 N 和 M,分别表示有向图的点和边的数量。
接下来 M 行,每行给出一条边的起点和终点。
点的编号从 1 到 N。(故代码中的 idx 初值置为 1,而不是常见的 0)
再一行包含一个整数 K,表示询问次数。
接下来 K 行,每行包含一个所有点的排列。
一行中的数字用空格隔开。
【输出格式】
在一行中输出所有不是拓扑序列的询问序列的编号。
询问序列编号从 0 开始。
行首和行尾不得有多余空格,保证存在至少一个解。
【数据范围】
1≤N≤1000,
1≤M≤10000,
1≤K≤100
【输入样例】
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
【输出样例】
3 4
【算法分析】
● 链式前向星:https://blog.csdn.net/hnjzsyjyj/article/details/139369904
val[idx]:存储编号为 idx 的边的值
e[idx]:存储编号为 idx 的结点的值
ne[idx]:存储编号为 idx 的结点指向的结点的编号
h[a]:存储头结点 a 指向的结点的编号
【算法代码】
#include <bits/stdc++.h>
using namespace std;
const int maxn=1005;
const int maxm=10005;
int e[maxm],ne[maxm],h[maxn],idx=1;
int din[maxn]; //in-degree
int d[maxn]; //copy of in-degree
int a[maxn]; //ask
bool st[105];
int n,m;
void add(int a,int b) {
e[idx]=b,ne[idx]=h[a],h[a]=idx++;
}
bool topsort() {
for(int i=1; i<=n; i++) {
if(d[a[i]]) return false;
for(int j=h[a[i]]; j!=-1; j=ne[j])
d[e[j]]--;
}
return true;
}
int main() {
memset(h,-1,sizeof h);
cin>>n>>m;
for(int i=1; i<=m; i++) {
int x,y;
cin>>x>>y;
add(x,y);
din[y]++;
}
int k;
cin>>k;
for(int i=0; i<k; i++) {
for(int j=1; j<=n; j++) {
cin>>a[j];
d[j]=din[j];
}
if(topsort()) st[i]=1;
else st[i]=0;
}
for(int i=0; i<k; i++)
if(!st[i]) cout<<i<<" ";
return 0;
}
/*
in:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
out:
3 4
*/
【参考文献】
https://www.acwing.com/solution/content/68577/
https://www.acwing.com/solution/content/32730/