题目描述
给定 N个正整数,请统计奇数和偶数各有多少个?
输入格式
输入第一行给出一个正整 N(≤1000);第2行给出 N个非负整数,以空格分隔。
输出格式
在一行中先后输出奇数的个数、偶数的个数。中间以1个空格分隔。
输入样例
在这里给出一组输入。例如:
9
88 74 101 26 15 0 34 22 77
输出样例
在这里给出相应的输出。例如:
3
6
package com.ty.java;
import java.util.Scanner;
public class Height {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int N, o = 0, j = 0;
N = sc.nextInt();
for (int i = 0; i < N; i++) {
int n = sc.nextInt();
if (n % 2 == 0) {
o++;
} else {
j++;
}
}
System.out.println(j);
System.out.println(o);
}
}
代码运行如下:
com.ty.java.Height
9
88 74 101 26 15 0 34 22 77
3
6
Process finished with exit code 0