维护一个集合,初始时集合为空,支持如下几种操作:
I x
,插入一个数 x;PM
,输出当前集合中的最小值;DM
,删除当前集合中的最小值(数据保证此时的最小值唯一);D k
,删除第 k 个插入的数;C k x
,修改第 k 个插入的数,将其变为 x;
现在要进行 N 次操作,对于所有第 2 个操作,输出当前集合的最小值。
输入格式
第一行包含整数 N。
接下来 N 行,每行包含一个操作指令,操作指令为 I x
,PM
,DM
,D k
或 C k x
中的一种。
输出格式
对于每个输出指令 PM
,输出一个结果,表示当前集合中的最小值。
每个结果占一行。
数据范围
1≤N≤
−≤x≤
数据保证合法。
输入样例:
8
I -10
PM
I -10
D 1
C 2 8
I 6
PM
DM
输出样例:
-10
6
代码:
#include<iostream>
#include<string.h>
using namespace std;
const int N = 100010;
int heap[N],ph[N],hp[N];
int n,len;
void heap_swap(int a,int b){
swap(ph[hp[a]],ph[hp[b]]);
swap(hp[a],hp[b]);
swap(heap[a],heap[b]);
}
void down(int x){
int target = x;
if(2*x <= len && heap[2*x] < heap[target]){
target = 2*x;
}
if(2*x + 1<= len && heap[2*x + 1] < heap[target]){
target = 2*x + 1;
}
if(target != x){
heap_swap(target,x);
down(target);
}
}
void up(int x){
while(x/2 != 0 && heap[x/2] > heap[x]){
heap_swap(x,x/2);
x /= 2;
}
}
int main(){
cin>>n;
string op;
int a,k,m = 0;
while(n--){
cin>>op;
if(op == "I"){
cin>>a;
len++;
heap[len] = a;
m++;
ph[m] = len;
hp[len] = m;
up(len);
}else if(op == "PM"){
cout<<heap[1]<<endl;
}else if(op == "DM"){
heap_swap(len,1);
len--;
down(1);
}else if(op == "D"){
cin>>k;
k = ph[k];
heap_swap(k,len);
len--;
down(k);
up(k);
}else if(op == "C"){
cin>>k>>a;
k = ph[k];
heap[k] = a;
down(k);
up(k);
}
}
return 0;
}