“六度空间”理论又称作“六度分隔(Six Degrees of Separation)”理论。这个理论可以通俗地阐述为:“你和任何一个陌生人之间所间隔的人不会超过六个,也就是说,最多通过五个人你就能够认识任何一个陌生人。”如图1所示。
图1 六度空间示意图
“六度空间”理论虽然得到广泛的认同,并且正在得到越来越多的应用。但是数十年来,试图验证这个理论始终是许多社会学家努力追求的目标。然而由于历史的原因,这样的研究具有太大的局限性和困难。随着当代人的联络主要依赖于电话、短信、微信以及因特网上即时通信等工具,能够体现社交网络关系的一手数据已经逐渐使得“六度空间”理论的验证成为可能。
假如给你一个社交网络图,请你对每个节点计算符合“六度空间”理论的结点占结点总数的百分比。
输入格式:
输入第1行给出两个正整数,分别表示社交网络图的结点数N(1<N≤103,表示人数)、边数M(≤33×N,表示社交关系数)。随后的M行对应M条边,每行给出一对正整数,分别是该条边直接连通的两个结点的编号(节点从1到N编号)。
输出格式:
对每个结点输出与该结点距离不超过6的结点数占结点总数的百分比,精确到小数点后2位。每个结节点输出一行,格式为“结点编号:(空格)百分比%”。
输入样例:
10 9
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
输出样例:
1: 70.00%
2: 80.00%
3: 90.00%
4: 100.00%
5: 100.00%
6: 100.00%
7: 100.00%
8: 90.00%
9: 80.00%
10: 70.00%
代码实现:
#include<stdio.h>
#include<stdlib.h>
typedef struct ArcNode* Arc;
struct ArcNode
{
int adjvex;
Arc next;
};
Arc graph[1005];
void init(int M);
int bfs(int);
void test(int);
void createNode(int v1,int v2)
{
Arc newnode=(Arc)malloc(sizeof(struct ArcNode));
newnode->next=NULL;
newnode->adjvex=v2;
if(graph[v1]==NULL)
{
graph[v1]=newnode;
}
else
{
Arc pre=graph[v1];
Arc cur=pre->next;
while(cur!=NULL)
{
pre=cur;
cur=cur->next;
}
pre->next=newnode;
}
//
Arc node=(Arc)malloc(sizeof(struct ArcNode));
node->next=NULL;
node->adjvex=v1;
if(graph[v2]==NULL)
{
graph[v2]=node;
}
else
{
Arc pre=graph[v2];
Arc cur=pre->next;
while(cur!=NULL)
{
pre=cur;
cur=cur->next;
}
pre->next=node;
}
//
return;
}
int main()
{
int N,M;
scanf("%d%d",&N,&M);
init(N);
for(int i=0;i<M;i++)
{
int v1,v2;
scanf("%d%d",&v1,&v2);
createNode(v1,v2);
}
//
for(int i=1;i<=N;i++)
{
float res=bfs(i);
float rate=res/N;
rate*=100;
printf("%d: %.2f%%\n",i,rate);
}
//
return 0;
}
void init(int N)
{
for(int i=0;i<=N;i++)
{
graph[i]=NULL;
}
return;
}
int bfs(int vex)
{
int cnt=0;
int st[1005]={0};
int queue[1005];
int head=0,tail=0;
queue[tail++]=vex;
st[vex]=1;
while(head<tail)
{
int v1=queue[head++];
cnt++;
Arc temp=graph[v1];
if(st[v1]<7)
while(temp!=NULL)
{
int v2=temp->adjvex;
if(st[v2]!=0)
{
temp=temp->next;
continue;
}
else
{
st[v2]=st[v1]+1;
queue[tail++]=v2;
temp=temp->next;
}
}
}
return cnt;
}
void test(int vex)
{
Arc cur=graph[vex];
while(cur!=NULL)
{
printf("%d ",cur->adjvex);
cur=cur->next;
}
printf("\n");
return;
}
本题应该使用邻接表作为存储结构,邻接矩阵的时间复杂度为n^2会超时。