eNSP中小型园区网络拓扑搭建(上)

→b站直通车,感谢大佬←

→eNSP中小型园区网络拓扑搭建(下)←

不带配置命令的拓扑图已上传~

在这里插入图片描述

项目背景:

  • 某公司准备新建一张网络供企业办公使用。写字楼共3层,一层会客大厅、二层行政部及市场部、三层研发部。一层设有核心机房,其他各楼层均有一个小房间放置网络设备。
  • 在网络中终端分部量如下:一层:10台有线终端。二层和三层:均有200台有线终端,50台无线终端。在企业网络内,主要流量为内部流量,保证有线终端至少百兆接入。
  • 在网络设计时,二三层网络都需要有一定的冗余与故障切换能力,保证业务不会因故障而中断。出于安全性需求,需要对网络流量做一定程度的管控。在园区出口处,采用静态ip方式接入互联网。

会客大厅、行政部及市场部、研发部、FTP服务器、外网

基础需求:

  1. 仅允许访客区可以访问internet,不允许访问其他部门
  2. 市场部与行政部之间可以相互访问,但不允许访问研发部
  3. .研发部作为公司核心部门,掌握公司核心数据,仅允许其访问ftp服务器,不允许其访问其他部门和访问internet

安全调优:

  1. 二层安全
  • 在二层网络中确保根桥位置不被抢占(根防护)
  • 确保连接终端接口不能接受处理budu(bpdu防护)
  • 连接终端的接口要快速进入转发状态(边缘端口)
  • 为抵御mac范洪攻击,需要在交换机上限制学习mac地址的数量(端口安全)
  1. 三层安全
  • 仅允许访客区可以访问Internet,不允许访问其他任何部门

  • 市场部与行政部之间可以互相访问,但不允许访问研发部

  • 研发部作为公司核心部门,掌握公司核心数据,仅允许其访问FTP服务器,不允许其 访问其他部门和访问Internet

vlan设计

  • 核心机房的接入交换机直接连接服务器,所有服务器属于同一个vlan
  • 一层访客大厅规划单独的vlan
  • 二楼行政部和市场部属于不同的vlan
  • 三楼研发部规划到不同的vlan
  • 交换机所有互联接口需要明确放行所需vlan(不能放行all)
  • 另外注意预留设备互联vlan,设备管理vlan,每台交换设备需要配置一个管理vlan,方便后期进行监控管理

SW1~4,SW7

#
vlan batch 10 20 30 40 100 200
#

SW1

#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 10
#

SW2

#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 20
#

SW3

#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 30
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 30
#
interface GigabitEthernet0/0/3
  port link-type trunk
 port trunk allow-pass vlan 30
#

SW4

#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 40
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 40
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 40
#

SW7

#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 200
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 200
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 200
#

SW5

#
vlan batch 10 20 30 40 51 52 61 62 100 200
#

//链路聚合
[SW5]int Eth-Trunk 1
[SW5-Eth-Trunk1]trunkport g0/0/11
[SW5-Eth-Trunk1]trunkport g0/0/12

#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 30
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 40
#
interface GigabitEthernet0/0/5
 port link-type trunk
 port trunk allow-pass vlan 200
#
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 51
#
interface GigabitEthernet0/0/7
 port link-type access
 port default vlan 52
#

SW6

#
vlan batch 10 20 30 40 51 52 61 62 100 200
#

//链路聚合
[SW6]int Eth-Trunk 1
[SW6-Eth-Trunk1]trunkport g0/0/11
[SW6-Eth-Trunk1]trunkport g0/0/12

#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 30
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 40
#
interface GigabitEthernet0/0/5
 port link-type trunk
 port trunk allow-pass vlan 200
#
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 62
#
interface GigabitEthernet0/0/7
 port link-type access
 port default vlan 61
#

SW8

[SW8]v b 18 28 100
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 100
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 18
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 28
#

二层环路消除

  • 使用mstp防环,所有交换机网络处于相同mstp域,域名为tjise
  • 要求生成树的根桥集中在汇聚层,并且考虑未来部署vrrp时,为避免次优路径,vrrp的master与mstp根桥保持一致。
  • 对于设备间互联的多条链路,使用链路聚合来消除环路

SW1~7

#
stp region-configuration
 region-name tjise
 instance 1 vlan 10
 instance 2 vlan 20 30
 instance 4 vlan 40
 instance 5 vlan 200
 active region-configuration
#

SW5

[SW5]stp instance 1 root primary 
[SW5]stp instance 2 root primary 
[SW5]stp instance 4 root secondary 
[SW5]stp instance 5 root secondary 

SW6

[SW6]stp instance 1 root  secondary
[SW6]stp instance 2 root  secondary
[SW6]stp instance 4 root primary 
[SW6]stp instance 5 root primary 

三层网络设计

  • 网络地址层规划
  • ip地址设计要与vlan编号形成对应关系
  • 除设备互联vlan、管理vlan以及服务器ip地址外,其他终端的ip地址均用dhcp动态分配

SW5

#
interface Vlanif10
 ip address 192.168.10.5 255.255.255.0
 vrrp vrid 10 virtual-ip 192.168.10.254
 vrrp vrid 10 priority 120
#
interface Vlanif20
 ip address 192.168.20.5 255.255.255.0
 vrrp vrid 20 virtual-ip 192.168.20.254
 vrrp vrid 20 priority 120
#
interface Vlanif30
 ip address 192.168.30.5 255.255.255.0
 vrrp vrid 30 virtual-ip 192.168.30.254
 vrrp vrid 30 priority 120
#
interface Vlanif40
 ip address 192.168.40.5 255.255.255.0
 vrrp vrid 40 virtual-ip 192.168.40.254
#
interface Vlanif51
 ip address 192.168.51.5 255.255.255.0
#
interface Vlanif52
 ip address 192.168.52.5 255.255.255.0
#
interface Vlanif200
 ip address 192.168.200.5 255.255.255.0
 vrrp vrid 200 virtual-ip 192.168.200.254
#

SW6

#
interface Vlanif10
 ip address 192.168.10.6 255.255.255.0
 vrrp vrid 10 virtual-ip 192.168.10.254
#
interface Vlanif20
 ip address 192.168.20.6 255.255.255.0
 vrrp vrid 20 virtual-ip 192.168.20.254
#
interface Vlanif30
 ip address 192.168.30.6 255.255.255.0
 vrrp vrid 30 virtual-ip 192.168.30.254
#
interface Vlanif40
 ip address 192.168.40.6 255.255.255.0
 vrrp vrid 40 virtual-ip 192.168.40.254
 vrrp vrid 40 priority 120
#
interface Vlanif61
 ip address 192.168.61.6 255.255.255.0
#
interface Vlanif62
 ip address 192.168.62.6 255.255.255.0
#
interface Vlanif200
 ip address 192.168.200.6 255.255.255.0
 vrrp vrid 200 virtual-ip 192.168.200.254
 vrrp vrid 200 priority 120
#

SW8

#
interface Vlanif18
 ip address 192.168.18.8 255.255.255.0
#
interface Vlanif28
 ip address 192.168.28.8 255.255.255.0
#
interface Vlanif100
 ip address 192.168.100.8 255.255.255.0
#

Server-ftp
在这里插入图片描述
在这里插入图片描述

AR1

#
interface GigabitEthernet0/0/0
 ip address 192.168.51.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.52.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 192.168.13.1 255.255.255.0 
#
interface GigabitEthernet3/0/0
 ip address 192.168.18.1 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 192.168.12.1 255.255.255.0 
#

AR2

#
interface GigabitEthernet0/0/0
 ip address 192.168.62.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.61.2 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 192.168.23.2 255.255.255.0 
#
interface GigabitEthernet3/0/0
 ip address 192.168.28.2 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 192.168.12.2 255.255.255.0 
#

AR3

#
interface GigabitEthernet0/0/0
 ip address 123.123.123.3 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.13.3 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 192.168.23.3 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 123.123.124.3 255.255.255.0 
#

Server2
在这里插入图片描述

配置DHCP

AR-DHCP

#
ip pool vlan10
 gateway-list 192.168.10.254 
 network 192.168.10.0 mask 255.255.255.0 
 excluded-ip-address 192.168.10.5 192.168.10.6 
#
ip pool vlan20
 gateway-list 192.168.20.254 
 network 192.168.20.0 mask 255.255.255.0 
 excluded-ip-address 192.168.20.5 192.168.20.6 
#
ip pool vlan30
 gateway-list 192.168.30.254 
 network 192.168.30.0 mask 255.255.255.0 
 excluded-ip-address 192.168.30.5 192.168.30.6 
#
ip pool vlan40
 gateway-list 192.168.40.254 
 network 192.168.40.0 mask 255.255.255.0 
 excluded-ip-address 192.168.40.5 192.168.40.6 
#

[AR-DHCP]dhcp en

#
interface GigabitEthernet0/0/0
 ip address 192.168.200.1 255.255.255.0 
 dhcp select global
#

SW5 SW6

[SW5]dhcp en
[SW5]int vlan 10
[SW5-Vlanif10]dhcp select relay
[SW5-Vlanif10]dhcp relay server-ip 192.168.200.1

[SW5]int vlan 20
[SW5-Vlanif10]dhcp select relay
[SW5-Vlanif10]dhcp relay server-ip 192.168.200.1

[SW5]int vlan 30
[SW5-Vlanif10]dhcp select relay
[SW5-Vlanif10]dhcp relay server-ip 192.168.200.1

[SW5]int vlan 40
[SW5-Vlanif10]dhcp select relay
[SW5-Vlanif10]dhcp relay server-ip 192.168.200.1

PC成功获取到ip地址
在这里插入图片描述

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:/a/615430.html

如若内容造成侵权/违法违规/事实不符,请联系我们进行投诉反馈qq邮箱809451989@qq.com,一经查实,立即删除!

相关文章

探讨 vs2019 c++ 里函数指针与函数类型在使用上的语法区别

(1)咱们可以用 decltype () 来判断函数的类型。但以这个类型定义有用的可指向已存在函数的变量,却行不通。测试如下: 如果把上面的注释去掉会报错: 所以函数类型只有语法意义。但在使用上没有函…

InputStream,OutputStream的用法以及相应的案例

1. 文件系统的操作:File类。 2. 文件内容的操作:Stream流。 字符流:IntputStream , OutputStream。 字节流:read , write。 InputStream,OutputStream InputStream和OutputStream都不能被实例…

论文笔记:DeepMove: Predicting Human Mobility with Attentional Recurrent Networks

WWW 2018 1 Intro 根据对百万级用户群的研究,93%的人类移动是可预测的。 早期的mobility预测方法大多基于模式的。 首先从轨迹中发现预定义的移动模式(顺序模式、周期模式)然后基于这些提取的模式预测未来位置。最近的发展转向基于模型的方法进行流动性预测。 利用…

Django性能之道:缓存应用与优化实战

title: Django性能之道:缓存应用与优化实战 date: 2024/5/11 18:34:22 updated: 2024/5/11 18:34:22 categories: 后端开发 tags: 缓存系统Redis优点Memcached优缺点Django缓存数据库优化性能监控安全实践 引言 在当今的互联网时代,用户对网站和应用…

阿里云Redis创建使用

说明:本文介绍如何使用阿里云Redis,包括开通、连接、使用; 开通 进入官网Redis产品页,点击免费试用(白嫖); 选择中间这个,云数据库Redis版; 开通完成后,可在…

应对【核弹级风险】,中小企业如何构建【轻量级】开源治理策略?

开源 三句半 开源治理建团队 制度工具要完善 积极参与开源事 深度实践! 4月份曝光的“XZ后门事件”是一起历时两年半的“开源供应链投毒”典型案例,被定义为“核弹级漏洞事件”,其揭示了开源技术的安全短板,引发了众多企业的紧急…

C++青少年简明教程:基础知识

C青少年简明教程:基础知识 电脑程序设计(Computer programming),或称程序设计(programming),是给出解决特定问题程序的过程,程序设计往往以某种程序设计语言为工具,给出这…

【Android】Kotlin学习之Kotlin方法的声明和传参

方法声明 普通类的方法 静态类的方法 不需要构建实例对象, 可以通过类名直接访问静态方法 : NumUtil.double(1) companion object 伴生类的方法 使用companion object 在普通类里定义静态方法 参数 括号内传入方法 : 当参数是方法时, 并且是最后一个参数 , 可以使用括号外…

关于DDD和COLA的一些总结和思考

1|0思维:面向对象和面向过程 领域驱动设计本质上是讲的面向对象,但是谈面向对象,始终无法绕开面向过程,所以我们先好好说一下面向过程和面向对象这两个概念。 什么是面向过程呢,其实就是我们学习编程时最初被植入的逻辑…

Redis 实战之事务的实现

事务的实现 事务开始命令入队事务队列执行事务总结 一个事务从开始到结束通常会经历以下三个阶段: 1、 事务开始; 2、 命令入队; 3、事务执行。 本节接下来的内容将对这三个阶段进行介绍, 说明一个事务从开始到结束的整个过程。 …

【QVariant类型剖析】

QVariant类型剖析 🌟 官方文档中给出的定义🌟 特性🌸QVariant实战应用🌸项目成果展示 🌟 官方文档中给出的定义 📘Because C forbids unions from including types that have non-default constructors or…

(Java)心得:LeetCode——5.最长回文子串

一、原题 给你一个字符串 s,找到 s 中最长的回文子串。 如果字符串的反序与原始字符串相同,则该字符串称为回文字符串。 示例 1: 输入:s "babad" 输出:"bab" 解释:"aba"…

Java并发编程及并发包中类分析

一、并发编程线程基础: 1.什么是线程: 线程是进程中的一个实体,线程本身是不会独立存在的进程是代码在数据集合上的一 次运行活动 , 是系统进行资源分配和调度的基本单位 线程则是进程的 执行路径, 一 个进程中至少有…

2024年5月10日有感复盘

2024年5月10日有感复盘 时间 今天是一个很美好的一天,原因是很平凡,读书很平凡,玩游戏很平凡,然后生活很平凡,未来可期,听歌很舒服,很喜欢一个人呆在图书馆的感觉,很喜欢发呆&…

串口属性中的BM延时计时器问题

如果使用程序修改则需要修改注册表对应位置如下 第一个示例&#xff08;217&#xff09; 第二个示例&#xff08;219&#xff09; 需要注意的事情是修改前必须点查看串口名称&#xff08;例如上图是com5&#xff09; 程序修改&#xff1a; 有没有办法以编程方式更改USB <…

2024第十六届“中国电机工程学会杯”数学建模A题B题思路分析

文章目录 1 赛题思路2 比赛日期和时间3 竞赛信息4 建模常见问题类型4.1 分类问题4.2 优化问题4.3 预测问题4.4 评价问题 5 建模资料 1 赛题思路 (赛题出来以后第一时间在CSDN分享) https://blog.csdn.net/dc_sinor?typeblog 2 比赛日期和时间 报名截止时间&#xff1a;2024…

vuex核心概念-actions

目录 一、概述 二、应用场景 三、使用步骤 三、注意 四、辅助函数-mapActions 一、概述 目标&#xff1a;明确actions的基本语法&#xff0c;处理异步操作。 需求&#xff1a;一秒钟之后&#xff0c;修改state的count成666。 说明&#xff1a;mutations必须是同步的(便于…

geotrust企业通配符证书2990

随着时代的变化&#xff0c;人们获取信息的方式由报纸、书籍变为手机、电脑&#xff0c;因此很多企事业单位用户开始在互联网中创建网站来进行宣传&#xff0c;吸引客户。为了维护网站安全环境&#xff0c;保护客户数据&#xff0c;企事业单位也开始使用SSL数字证书&#xff0c…

spfa检测负权回路C++

1.负权边回路首先dist数组刚开始初始化是0&#xff0c;&#xff08;因为是检测回路&#xff0c;那么无论从哪里开始起点都是一样的&#xff0c;所以一开始就会把所有点都加载到队列中&#xff0c;所以就相当于把dist[所有点] 0&#xff09;&#xff1b;下面就是cnt数组----很多…

LeetCode例题讲解:844.比较含退格的字符串

给定 s 和 t 两个字符串&#xff0c;当它们分别被输入到空白的文本编辑器后&#xff0c;如果两者相等&#xff0c;返回 true 。# 代表退格字符。 注意&#xff1a;如果对空文本输入退格字符&#xff0c;文本继续为空。 示例 1&#xff1a; 输入&#xff1a;s "ab#c&qu…