分数 30
全屏浏览题目
切换布局
作者 CHEN, Yue
单位 浙江大学
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 00
.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
Special thanks to Zhang Yuan and Yang Han for their contribution to the judge's data.
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
const int N=105;
int n,m,s;
int w[N];//存放结点权值
vector<int>v[N];//存放各非叶节点的孩子节点
vector<vector<int>>ans;//存放路径
void dfs(int u,int sum,vector<int>&path){//深度遍历
bool leaf=true;
if(v[u].size())leaf=false;//若有孩子则不是叶结点
if(leaf){//如果是叶结点
if(sum==s)ans.push_back(path);//若此时权值符合,则放到ans里
}
else{//若不是叶结点
if(v[u].size()){//若该节点有孩子
for(int j=0;j<v[u].size();j++){//暴搜
path.push_back(w[v[u][j]]);//把当前结点的权值加入路径
dfs(v[u][j],sum+w[v[u][j]],path);//深度遍历
path.pop_back();//恢复现场
}
}
}
}
int main(){
cin>>n>>m>>s;
for(int i=0;i<n;i++)cin>>w[i];//输入各结点权值
while(m--){//输入m个非叶节点
int id,k;
cin>>id>>k;
while(k--){//保存结点的孩子
int kid;
cin>>kid;
v[id].push_back(kid);
}
}
vector<int>path({w[0]});//权值路径,一开始只有根结点权值
dfs(0,w[0],path);//深度遍历
sort(ans.begin(),ans.end(),greater<vector<int>>());//按字典序从大到小排列
for(auto t:ans){//迭代器遍历
cout<<t[0];
for(int i=1;i<t.size();i++)cout<<" "<<t[i];
cout<<endl;
}
return 0;
}